インテル® VTune™ プロファイラー・ユーザーガイド

Windows* ターゲット

Windows* ターゲットのパフォーマンス解析にインテル® VTune™ プロファイラーを使用します。

Windows* ターゲットの解析準備

ターゲットのパフォーマンス解析を始める前に、次のことを行う必要があります。

Visual Studio* IDE からターゲットを選択

Microsoft* Visual Studio* IDE に統合されたインテル® VTune™ プロファイラー では、開発環境から直接解析ターゲットを選択してパフォーマンス解析を実行できます。

既存のソリューションで解析ターゲットを選択するには、

  1. [Intel VTune Profiler Results] フォルダーのソリューションを開きます。フォルダーを表示するには、Visual Studio* IDE で [表示] > [その他のウィンドウ] > [Intel VTune Profiler Results] を選択します。

  2. ソリューションに複数のプロジェクトが含まれている場合、対象とするプロジェクトを選択します。

    インテル® VTune™ プロファイラーのツールバーとメニューアイテムが有効になります。デフォルトで、インテル® VTune™ プロファイラーは Visual Studio* の設定を引き継ぎ、解析ターゲットとしてアプリケーションを作成するために選択されているプロジェクトを使用します。プロジェクトを右クリックして、ツールバーの [解析の設定] ツールバーボタンを選択して、メニューからターゲットのプロパティーを確認します。デフォルトでは、ターゲットタイプは [アプリケーションを起動] に設定されます。

既存のスランドアロン実行ファイルを選択します:

  1. Visual Studio* のメニューから、[ファイル] > [開く] > [プロジェクト/ソリューション] を選択します。

    [プロジェクトを開く] ダイアログボックスが表示されます。

  2. [Exe プロジェクトファイル (*.exe)] フィルターを選択し、実行形式ファイルを選びます。

    Visual Studio* ソフトウェアは、実行可能ファイルを含む単一プロジェクトのソリューションを作成します。インテル® VTune™ プロファイラーの機能が有効になります。

  3. プロジェクトを右クリックし、[Intel VTune Profiler version ] > [解析の設定] オプションを選択します。

    [解析の設定] ウィンドウが開きます。

  4. 下部にある [バイナリー/シンボル検索] または [ソース検索] ボタンをクリックして [検索ディレクトリー] を指定します。デフォルトでは、検索ディレクトリーは Microsoft* Visual Studio* のプロジェクト・プロパティーから継承されます。Visual Studio* でシステム関数の既存のプロジェクト検索ディレクトリーを確認するには、ソリューション・エクスプローラーでプロジェクトを右クリックして、プロパティーを選択します。

    収集されたデータをファイナライズする際に、インテル® VTune™ プロファイラーはこれらのディレクトリーを参照して、バイナリー (実行可能形式とダイナミック・ライブラリー)、シンボル (通常は .pdb ファイル)、およびターゲットのソースファイルを特定の順番で検索します。インテル® VTune™ プロファイラーは、アプリケーションをビルドしてパフォーマンス・データを収集した後、移動されていない C/C++ プロジェクトのファイルを自動的に検索します。

  5. ソリューションを保存します。

Visual Studio* のバージョンが異なると、ユーザー・インターフェイスも異なる可能性があります。操作法については Visual Studio* のオンラインヘルプをご覧ください。

Windows* ターゲットの設定

インテル® VTune™ プロファイラーのプロジェクトを作成し、[解析の設定] ウィンドウを開き、3 つのターゲットタイプのいずれかを選択します。[アプリケーションを起動][プロセスにアタッチ]、または [システムをプロファイル]。例えば、[アプリケーションを起動] ターゲットタイプでは、解析する対象のアプリケーション (必要であれば引数も) を指定する必要があります。

設定が完了したら、[どのように] ペインの右上にある 実行する解析タイプを選択ボタンをクリックして、解析タイプを選択して実行します。

関連情報